EFT (credit card processing) service interruption (Concardis only)
Incident Report for protel Cloud Center
Resolved
Our development team has investigated the cause.
All our services are running stable. If the problem still persists, please contact Concardis directly.
Posted Jun 20, 2021 - 12:10 CEST
Investigating
Some Concardis EFT customers are reporting issues with credit card processing at the moment. We are working with our payment processing partner to identify the cause of the problem.
Posted Jun 20, 2021 - 09:08 CEST
This incident affected: protel Cloud Solutions | Europe, North America (Credit Card Interface).