protel Cloud Service Interruption
Incident Report for protel Cloud Center
Resolved
This incident has been resolved.
Posted May 12, 2021 - 02:51 CEST
Investigating
Access to individual protel services is currently interrupted for some customers. We are working to resolve this issue as soon as possible. View the current status and impacted services via https://cloudstatus.protel.net.
Posted May 12, 2021 - 02:20 CEST
This incident affected: protel Cloud Solutions | Europe, North America (protel Air).