protel Cloud Service Interruption
Incident Report for protel Cloud Center
Resolved
This incident has been resolved.
Posted Apr 14, 2021 - 15:58 CEST
Investigating
Access to individual protel services is currently interrupted for some customers. We are working to resolve this issue as soon as possible. View the current status and impacted services via https://cloudstatus.protel.net.
Posted Apr 14, 2021 - 15:41 CEST
This incident affected: protel Cloud Solutions | Europe, North America (protel Air) and protel Cloud Solutions | Australia, Asia (protel Air).