protel Cloud Service Degraded Performance
Incident Report for protel Cloud Center
Resolved
This incident has been resolved.
Posted Mar 14, 2023 - 13:29 CET
Update
We are continuing to investigate this issue.
Posted Mar 13, 2023 - 20:28 CET
Investigating
Dear Customers,
At the moment you may not be able to reach us by phone. Please send us an email to support@protel.net or open a ticket via our service desk. We will monitor the incoming tickets more than usually and act according to priority. we apologize for the inconvenience.
You can still reach us via 0800 180 0894
Your protel support
Posted Mar 13, 2023 - 20:12 CET
This incident affected: Other Systems or Components (protel Support - Telephone Availability).