protelAir Outage
Incident Report for protel Cloud Center
Postmortem

Problem Description

On 08.03.2024, the Cloud environment experienced a service disruption, starting at approximately 10:50 AM UTC+1.
A small surge load hit the Identity Server database, resulting in an outage, and making access to Protel Air PMS (Front Office) unavailable.
After identifying the root cause, we implemented a workable solution for immediate remedy. Afterwards, all systems were fully operational again at approximately 12:40 PM UTC+1.
To prevent such an incident from reoccurring, we have performed a thorough analysis of what happened and taken corrective measures. Our assessment of the fault, including future preventative actions, can be found below.

Affected systems

All protel services on the Cloud environment

Impact

Login to the Cloud environment was no longer possible, with a generic HTTP error message.

Root Cause

Around 10:50 AM UTC+1, a small surge of requests arrived at the Identity Server for unknown reasons.
One of the first steps to resolve the issue was to increase the database performance from XL to 2XL to make login possible as quickly as possible.
A closer examination was required here to find the root cause of the exceptionally high load on the database of the external Identity Management system. The results showed that the requests for the Identity systems steadily increased over the last two years. These requests are fulfilled partly by accessing a database table that aggregates more and more information over time. The surge, in combination with too-large table content, increased the load on the database to a breaking point, from where the processing of requests slowed down dramatically. After a very short time, newer requests were rejected, and error messages were returned.

Mitigation / Preventive Actions

Plans have been developed to improve the performance of the Identity and Access Management system in the short, medium, and long term.
● The short-term solution involves increasing the database performance from XL to 2XL.
● For the medium-term solution, we will reduce the data in the specific table that slowed down performance.
● The long-term solution will be replacing our current Identity & Access Management system with its newly developed successor. This replacement will also include using a different external Identity Management system, which is more suited for high-performance use.

Posted Mar 12, 2024 - 09:26 CET

Resolved
This incident has been resolved.
Posted Mar 08, 2024 - 15:03 CET
Update
We are continuing to monitor for any further issues.
Posted Mar 08, 2024 - 13:29 CET
Update
We are continuing to monitor for any further issues.
Posted Mar 08, 2024 - 12:53 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2024 - 12:39 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 08, 2024 - 12:09 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 08, 2024 - 11:42 CET
Update
Dear customers,
we are continuing to investigate the current outage and working hard to find a solution.
Please note that we are difficult to reach by phone due to the large number of calls.
Posted Mar 08, 2024 - 11:30 CET
Investigating
Access to individual protel services is currently interrupted for some customers. We are working to resolve this issue as soon as possible. View the current status and impacted services via https://cloudstatus.protel.net.
Posted Mar 08, 2024 - 11:01 CET
This incident affected: protel Cloud Solutions | Europe, North America (protel Air, protel WBE - Web Booking Engine, protel IDS Interface, protel BWI Interface (Best Western International Interface), Other interfaces to local systems, protel Cloud Center Services, protel Air System Data, Identity and Access Management (IAM), protelAir elastic searchbar), protel.I/O (protel.I/O services for protel onPremise (SPE/MPE), protel.I/O services for protel AIR, protel.I/O services for individual 3rd party vendors), and protel Cloud Solutions | Australia, Asia (protel Air, protel WBE - Web Booking Engine, protel IDS Interface, protel BWI Interface (Best Western International Interface), protel Cloud Center Services, protel Air System Data, Identity and Access Management (IAM), protelAir elastic search bar).