protel Cloud Service PCI + Print Degraded Performance
Incident Report for protel Cloud Center
Resolved
This incident has been resolved.
Posted Apr 03, 2024 - 15:25 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2024 - 14:06 CEST
Update
We are continuing to investigate this issue.
Posted Apr 03, 2024 - 14:01 CEST
Investigating
We are aware that some customers are currently experiencing degraded system performance for PCI and Print. We're working with priority to get things back to normal. View the current status and impacted services via https://cloudstatus.protel.net.
Posted Apr 03, 2024 - 13:50 CEST
This incident affected: protel Cloud Solutions | Europe, North America (protel Air), protel Cloud Solutions | Africa (protel Cloud PMS), and protel Cloud Solutions | Australia, Asia (protel Air).