protel Cloud Service Degraded Performance
Incident Report for protel Cloud Center
Resolved
This incident has been resolved.
Posted Nov 26, 2021 - 10:14 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 26, 2021 - 08:44 CET
Investigating
We are aware that some customers are currently experiencing degraded system performance. We're working with priority to get things back to normal. View the current status and impacted services via https://cloudstatus.protel.net.
Posted Nov 26, 2021 - 08:27 CET
This incident affected: protel Cloud Solutions | Europe, North America (protel Air, protel Air System Data).