protel Cloud Service Degraded Performance

Incident Report for protel Cloud PMS

Monitoring

The corrective measures were successfully implemented. The systems are stable, and we are observing performance to ensure consistency.
Posted Mar 18, 2026 - 21:16 CET

Investigating

We are aware that some customers are currently experiencing degraded system performance. We're working with priority to get things back to normal. View the current status and impacted services via https://cloudstatus.protel.net.
Posted Mar 18, 2026 - 14:02 CET
This incident affects: protel Cloud Solutions | Europe, North America (protel Cloud PMS, protel Air System Data).