Nexi Integration Degraded Performance

Incident Report for protel Cloud Center

Resolved

Dear Customers,

We got the information from nexi that the connection is stabil again. For further information please contact Nexi
Posted Aug 21, 2025 - 11:43 CEST

Investigating

We are aware that some customers are currently experiencing degraded system performance with Nexi.

Nexi has been informed and is working with priority to get things back to normal.

View the current status and impacted services via https://cloudstatus.protel.net.
Posted Aug 21, 2025 - 10:25 CEST
This incident affected: protel Cloud Solutions | Europe, North America (Credit Card Interface, Other interfaces to local systems).