protel Cloud Service Degraded Performance

Incident Report for protel Cloud Center

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 15:33 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2025 - 15:11 CET

Investigating

We are aware that some customers are currently experiencing degraded system performance. We're working with priority to get things back to normal. View the current status and impacted services via https://cloudstatus.protel.net.
Posted Mar 21, 2025 - 14:07 CET
This incident affected: protel.I/O (protel.I/O services for protel onPremise (SPE/MPE), protel.I/O services for protel AIR, protel.I/O services for individual 3rd party vendors).