protel I/O Interfaces - Degraded Performance

Incident Report for protel Cloud PMS

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 23:45 CET

Investigating

We are aware that some customers are currently experiencing degraded system performance when importing and exporting through their I/O Interface. We are treating this with priority and working to restore normal performance as quickly as possible. You can view the current status and all impacted services at https://cloudstatus.protel.net.
Posted Mar 06, 2026 - 15:58 CET
This incident affected: protel.I/O (protel.I/O services for protel AIR).